The Red '96 Z26 (78K Miles)

Tell us about your Beretta and Post an Image
User avatar
Rettax3
Registered User
Posts: 1080
Joined: Mon Oct 22, 2012 3:34 pm

Re: '96 Z26-Vaccum Leak Nightmare NOT Solved... Yet!

Postby Rettax3 » Sat Jan 12, 2013 12:41 am

Money pit Beretta wrote:Last I remember the default is "on". That means that it will be purging all the time. That could have effect on the idle.

Mmm, close, but unless Jon corrects me, the Evap solenoid has power to it from an ignition-hot fuse (meaning power runs to it from a fuse if the ignition is on), but the ECM provides the ground circuit. It isn't actually open by default, though.

Interesting discussions regarding the heater-core though... I didn't read this post all the way through, so I may be out of line here, but the only Beretta I have that lost the heater-core was my '90 turbo (this was a little before I bought the car, maybe a year?), and when the core blew, it dumped all over the ground, NOT the carpet. The Berettas (at least the older ones, I can't swear about the later ones, but I would be surprised if they are different) have a drain-port to the OUTSIDE of the car, in the engine bay, that helps keep even catastrophic leaks from draining into the cabin of the car. I don't know how well this always works, but on my '90, it was 100% perfect, except for the complete PITA it was to change the blown core...


1989 Super Charged 3800 Series II (First)Six-Speed Conversion GTU
1990 Turbo 3.4 Five-Speed T-Type
1990 4.0L 4-Cam 32-Valve V-8 Five-Speed Indy GTi (Rebuild Project)
1990 Stock(!) 3.1 MPFI Auto Indy
1995 3400 Top-End Auto OD Z-26

User avatar
Money pit Beretta
Registered User
Posts: 6353
Joined: Thu Jul 26, 2007 11:36 am
Location: Kansas
Has thanked: 2 times
Been thanked: 8 times

Re: '96 Z26-Vaccum Leak Nightmare NOT Solved... Yet!

Postby Money pit Beretta » Sat Jan 12, 2013 2:07 pm

It's just something I read in a book. Some kind of safety feature to stop build up of fumes? Most of what I know comes from books.


keep'em flying!

2.2H8TA
Registered User
Posts: 915
Joined: Mon Aug 31, 2009 3:59 am
Location: NE-PA
Contact:

Re: The Red '96 Z26 (76K Miles)

Postby 2.2H8TA » Tue Jun 04, 2013 5:20 am

Ok, so an update on this headache now I guess. Car still has the same idle and evap problems! I had the coolant leak fixed a while back. It was leaking from the timing chain cover gasket. I had that done, along with a new belt tensoiner and belt. The IAC is causing the idle problem, these problems will get resolved sometime I'm sure, but it's still driveable, and runs good otherwise. My dads problems now I guess, as I've put almost every penny into it, up untill this most recent work. The damn A/C compressor has been making crazy noise lately, and it's going to be bypased soon. He's kind of afraid of driving the thing with the noise being this bad. I don't blame him. He will be driving my car on longer trips that he has to go on for the time being, untill the A/C bypass gets done or it stops making so much damn noise.
We are both on tight budgets, so things tend to get put off, but these cars are still in good hands.
This car is for sale locally still also, my dad wants a little S-10 EXT Cab 4Cyl 5 Speed. I've had a few offers, mostly junk trade offers, or lowball cash offers. I know nobody here will pay what we want for it, but maybe someone will, sometime.
Getting washed Tuesday too! I plan on getting pics of both cars together after the wash.
Last edited by 2.2H8TA on Sat Mar 29, 2014 3:08 pm, edited 1 time in total.


1994 AQUA ZED

2.2H8TA
Registered User
Posts: 915
Joined: Mon Aug 31, 2009 3:59 am
Location: NE-PA
Contact:

Re: The Red '96 Z26 (76K Miles)

Postby 2.2H8TA » Sun Sep 29, 2013 3:11 pm

Took a few new photos of the '96 Z today.
See link on first post.


1994 AQUA ZED

2.2H8TA
Registered User
Posts: 915
Joined: Mon Aug 31, 2009 3:59 am
Location: NE-PA
Contact:

Re: The Red '96 Z26 (76K Miles)

Postby 2.2H8TA » Thu Feb 27, 2014 1:35 am

Dead! No not the thread, the car. It sits with RUST!


1994 AQUA ZED

User avatar
Money pit Beretta
Registered User
Posts: 6353
Joined: Thu Jul 26, 2007 11:36 am
Location: Kansas
Has thanked: 2 times
Been thanked: 8 times

Re: The Red '96 Z26 (76K Miles)

Postby Money pit Beretta » Thu Feb 27, 2014 7:28 am

Why is it dead?


keep'em flying!

2.2H8TA
Registered User
Posts: 915
Joined: Mon Aug 31, 2009 3:59 am
Location: NE-PA
Contact:

Re: The Red '96 Z26 (76K Miles)

Postby 2.2H8TA » Sun Mar 02, 2014 4:00 am

Rust. I don't have photos on the computer, but it's nasty. It's fate will be determined when it gets warmer. For now it just sits, and gets ran. The rust prevents me from driving it, it will be driven less than 1 mile to a body shop, and we will go from there. I don't know if it's repairable, or affordable and worth it to have it repaired yet.


1994 AQUA ZED

User avatar
1988GTU
Registered User
Posts: 2744
Joined: Sat Mar 23, 2002 1:06 pm
Location: A town up north
Has thanked: 18 times
Been thanked: 11 times

Re: The Red '96 Z26 (78K Miles)

Postby 1988GTU » Sun Mar 02, 2014 7:41 am

How bad is the rust? Pics?


_________
Image
-------------

2.2H8TA
Registered User
Posts: 915
Joined: Mon Aug 31, 2009 3:59 am
Location: NE-PA
Contact:

Re: The Red '96 Z26 (78K Miles)

Postby 2.2H8TA » Sun Mar 02, 2014 7:38 pm

Here it is.
Attachments
IMG_20131228_112706.jpg


1994 AQUA ZED

User avatar
SummitBalt08
Registered User
Posts: 1062
Joined: Fri Jun 04, 2010 11:10 am
Location: Sidney, Ohio
Has thanked: 2 times
Been thanked: 3 times
Contact:

Re: The Red '96 Z26 (78K Miles)

Postby SummitBalt08 » Sun Mar 02, 2014 9:44 pm

How does a Beretta with 78k miles get that bad??

Somebody must have swapped a lower mileage cluster in it or something


-Shawn
Been on the Beretta Forums since '04
Image
94 Black Quad 5 spd Z26 ->3500 6 spd ZR6

Bfests '11,'12,'14
July 2012 Bnet Calendar

2.2H8TA
Registered User
Posts: 915
Joined: Mon Aug 31, 2009 3:59 am
Location: NE-PA
Contact:

Re: The Red '96 Z26 (78K Miles)

Postby 2.2H8TA » Sun Mar 02, 2014 11:33 pm

It's a true low mileage car. All of the rust is in the ass end. I have no idea why it's like this. Everything in front of the rear wheels is rust free.


1994 AQUA ZED

User avatar
SummitBalt08
Registered User
Posts: 1062
Joined: Fri Jun 04, 2010 11:10 am
Location: Sidney, Ohio
Has thanked: 2 times
Been thanked: 3 times
Contact:

Re: The Red '96 Z26 (78K Miles)

Postby SummitBalt08 » Mon Mar 03, 2014 1:14 am

I remember somebody saying that some of our cars had problems with the rear window gasket letting water into the trunk area down the shock tower. I bet your car has seen alot of rain


-Shawn
Been on the Beretta Forums since '04
Image
94 Black Quad 5 spd Z26 ->3500 6 spd ZR6

Bfests '11,'12,'14
July 2012 Bnet Calendar

User avatar
1988GTU
Registered User
Posts: 2744
Joined: Sat Mar 23, 2002 1:06 pm
Location: A town up north
Has thanked: 18 times
Been thanked: 11 times

Re: The Red '96 Z26 (78K Miles)

Postby 1988GTU » Mon Mar 03, 2014 3:35 am

I'd blame exhaust leaks to that kind of rust.


_________
Image
-------------

User avatar
themixer
Registered User
Posts: 1522
Joined: Fri Aug 14, 2009 12:13 pm
Location: Truro, Nova Scotia. Canada
Has thanked: 3 times
Been thanked: 16 times

Re: The Red '96 Z26 (78K Miles)

Postby themixer » Mon Mar 03, 2014 7:52 am

that is going to be expensive regardless of what you do.



User avatar
3X00-Modified
Administrator
Posts: 10664
Joined: Thu Jul 05, 2007 9:18 am
Location: Plainfield CT
Has thanked: 12 times
Been thanked: 46 times

Re: The Red '96 Z26 (78K Miles)

Postby 3X00-Modified » Mon Mar 03, 2014 10:45 am

I've only seen rear shock rust on the black 96 parts car I got... My 95 never had that issue but the spring perches are near gone... No idea how something like this happens, that's just nuts.

And at 78k it's still 18yrs old... that's plenty of time for something like this to happen if it's never been garaged. As soon as some rust starts in a spot back there it's only going to get worse with time...




Return to “Members Rides”

Who is online

Users browsing this forum: No registered users and 5 guests