Back after 10 years

Keep this to general Beretta/Board/Community topics.
enp3
Registered User
Posts: 11
Joined: Sun Sep 25, 2016 1:25 pm

Back after 10 years

Postby enp3 » Sun Sep 25, 2016 1:35 pm

I think it's been about 10 years since I last logged on and, while I found a few of my old threads, they now say "Guest" as poster. My '96 3100 base is still going at 233K. The trans issue I had starting at 125K finally turned into a critical problem at 208K.
viewtopic.php?f=8&t=307&hilit=Kristen

I pulled the trans & had it rebuilt. About a year later the timing cover gasket let go (Dexcool everywhere) and I really didn't think I'd get it out with the engine still in the car. I did manage to do it, however.



User avatar
ifixalot
Registered User
Posts: 536
Joined: Tue Dec 26, 2006 10:56 am
Location: Deerfield Illinois
Been thanked: 12 times

Re: Back after 10 years

Postby ifixalot » Tue Sep 27, 2016 9:08 am

Good to hear your Beretta is still going at 233K. Just sold my daughters at 203k miles since I had three Berettas.
Too much of a good thing can ruin it! haha
I wish you luck making it to 300K. Is yours a southern car? Usually it's structural rust that does these cars in.
Last edited by ifixalot on Fri Sep 30, 2016 5:15 pm, edited 1 time in total.



enp3
Registered User
Posts: 11
Joined: Sun Sep 25, 2016 1:25 pm

Re: Back after 10 years

Postby enp3 » Fri Sep 30, 2016 7:41 am

She lived up north from 96-2000, then I moved south. There have been brief forays into the salt since then but only when the roads of WNC have been treated (2-3x/yr). The snow usually disappears in less than a week. I'd say she's been "southernized."

I'll have to post a few pictures.




Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 7 guests